WordPress 2019: les avertissements en cas de PHP périmés

(Mis à jour le: 24 janvier 2019)
WordPress 2019: les avertissements en cas de PHP périmés
5 (100%) 1 vote


L’équipe en charge du développement des PHP recommande systématiquement des mises à jour à effectuer au niveau des sites de chaque utilisateur. L’année 2019 n’échappe pas à cette règle, en effet, le CMS (le système de gestion de contenu open-source) montre des avertissements aux administrateurs de site lorsque leur PHP est obsolète.

La version 5.6 lancée en 2014, le programme le plus utilisé du web encore aujourd’hui, est en train de perdre de son efficacité et son non mise à niveau pourrait engendrer des problèmes de sécurité sur certains sites internet.

Comment ?

L’avertissement des mises à jour sera lancé dès le printemps. Si les administrateurs des sites utilisent les portails de WordPress sur un environnement d’hébergement des plus contrôlé, l’hôte peut modifier le lien en une URL personnalisée reliée vers son propre site de support.

Pourquoi ?

Cette décision a été prise au mois de décembre dernier, après la sortie de WordPress version 5.0 qui a confirmé que la plupart des utilisateurs ont encore les versions PHP 5.6. Ce qui sous-entend que seule une partie de la communauté WP active bénéficiera de ces avertissements-là. De ce fait, ils ont pensé envoyer des avertissements pour les sites ayant une version plus âgée que la 5.6.

Dans quel but ?

Wordpress 2019

Le but est de faire en sorte que les utilisateurs actifs migrent vers des versions plus récentes de PHP pour que l’on quitte définitivement les anciennes versions.

L’équipe de WP veulent changer officiellement les tenants de la version PHP  de WP CMS en passant de PHP 5.2 à la version actuelle, PHP 5.6. Ainsi que pour les exigences de la version similaire, MySQL. Ensuite, à long terme, il faut faire en sorte que la version minimale nécessaire au fonctionnement de tous les sites sous WordPress aura la version 7.0 de PHP d’ici la fin de l’année.

Cette modification a pour cause le fait que l’équipe WP n’assurent plus la sécurité des sites sous les anciennes versions de PHP, ce qui les rend particulièrement vulnérables face aux attaques, exploitations,…

Les avantages d’une telle mesure sont :

-L’augmentation des capacités telles que l’efficacité et la rapidité de votre site web. La bonne visibilité sur les moteurs de recherches. Un site web plus rapide et plus efficace se verra plus facilement lors des recherches.

La sécurité de votre site web en sera renforcer et profitera des derniers modifications en termes de mesure de protection. Une bonne sécurité assure une bonne protection contre les piratages et les autres dommages et intérêts liés à ces actions.

Que doit-on faire ?

Il faut donc exécuter ces mises à jour car il ne faut jamais utiliser des programmes non maintenus qui ne bénéficient plus du tout d’une protection de sécurité et ne profitent pas des nouvelles options, thèmes, extensions,…

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Time limit is exhausted. Please reload CAPTCHA.